What are the browser compatibility requirements for a customer or an agent to use Lightico?

Lightico takes security seriously and protecting your organization and customers is our top priority. Our multi-layered security infrastructure has made Lightico a trusted technology partner for some of the world’s largest and most demanding companies.

To adhere to this, the end-customer or an agent's browser must be TLS 1.1 and TLS 1.2 compatible. 

If a browser does not support the newer TLS 1.1 and 1.2 versions, replacing or upgrading the browser with a more recent or supported version is necessary.

The following is an overview of the most commonly used desktop or mobile browsers, and their compatibility with TLS 1.1 and TLS 1.2

3pkpLoOvhP.png

What happens when an agent attempts to connect to Lightico with an unsupported browser? 

Different browsers may have a slightly different message. The message will indicate that a secure connection to the server could not be established. 

 

unsupported-browser.PNG

 

What happens when a customer attempts to open a Lightico invitation in an unsupported browser?

 

Different browsers may have a slightly different message. The message will indicate that a secure connection to the server could not be established. 

Here is an example of such message:

 

image0__2___1_.png

Was this article helpful?
0 out of 0 found this helpful